Flexible IT - Power Outage – Incident details

All systems operational

Power Outage

Resolved
Major outage
Started 17 days agoLasted about 1 hour
Updates
  • Resolved
    Resolved

    Power is still out, but no services are currently impacted.

  • Identified
    Identified

    We are experiencing a power outage in our office. As we shift resources, phone intake might be delayed. Besides a delay in phone intake, all relevant support systems are online and functional, and support will continue uninterrupted. For the fastest support, please leverage the MyFlex portal.