Flexible IT - Google Cloud Outage – Incident details

All systems operational

Google Cloud Outage

Resolved
Degraded performance
Started about 1 year agoLasted about 3 hours

Affected

MyFlex

Degraded performance from 6:33 PM to 9:10 PM

MyFlex Website

Degraded performance from 6:33 PM to 9:10 PM

Flexible IT API

Degraded performance from 6:33 PM to 9:10 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring

    Google services are beginning to recover, and as such, we are beginning to see improvement in the MyFlex app as well. We are continuing to monitor this issue.

  • Update
    UTC
    Update

    Google is still working on remediating a widespread Google Cloud issue that is impacting several of the services we use. We are continuing to monitor the situation.

  • Identified
    UTC
    Identified

    Due to a current outage related to Google Cloud services, we are experiencing issues with chat as well as a variety of other data connections. This is resulting in increased load times, and sometimes data not loading at all. Google is currently working to mitigate the issue.