Scheduled for January 10, 2026 at 9:30 PM – 10:36 PM
Affects
MyFlex
Under maintenance from 9:30 PM to 10:36 PM
MyFlex Website
Under maintenance from 9:30 PM to 10:36 PM
Flexible IT API
Under maintenance from 9:30 PM to 10:36 PM
Completed
January 10, 2026 at 10:36 PMCompleted
January 10, 2026 at 10:36 PMMaintenance has completed successfully.
In progress
January 10, 2026 at 9:30 PMIn progress
January 10, 2026 at 9:30 PMMaintenance is now in progress
Planned
January 10, 2026 at 9:30 PMPlanned
January 10, 2026 at 9:30 PMIn an effort to modernize the MyFlex platform, we will be performing some system maintenance on Saturday January 10 between 4:30PM and 6:30PM EST. During this time, the MyFlex system may be unavailable. If you need assistance while the system is down, please call (631) 815-1800 for support.