Flexible IT - Cloudflare Global Outage – Incident details

All systems operational

Cloudflare Global Outage

Resolved
Major outage
Started 27 days agoLasted about 5 hours

Affected

MyFlex

Major outage from 11:30 AM to 4:02 PM

MyFlex Website

Major outage from 11:30 AM to 4:02 PM

Flexible IT API

Major outage from 11:30 AM to 4:02 PM

Updates
  • Resolved
    Resolved

    All MyFlex and Flexible IT API systems appear to be functioning normally at this time. We will continue to monitor the situation with Cloudflare throughout the day.

  • Monitoring
    Monitoring

    Cloudflare has released a fix and service is beginning to restore. We are continuing to monitor.

  • Identified
    Identified

    Cloudflare is currently experiencing a global outage which is impacting both MyFlex and the Flexible IT API. We are currently monitoring the situation.