Flexible IT - Issues with Task Creation – Incident details

All systems operational

Issues with Task Creation

Resolved
Degraded performance
Started 7 months agoLasted about 3 hours

Affected

MyFlex

Degraded performance from 4:39 PM to 7:50 PM

Flexible IT API

Degraded performance from 4:39 PM to 7:50 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We've implemented a workaround and are continuing to monitor. Performance should be improved.

  • Identified
    Identified

    We've identified an issue with task creation; it may take significantly longer to create tasks, and some tasks may be given a title of "New Task". This issue is caused by a Microsoft outage regarding their AI services.